FreeBSD Build Items

.xinitrc

#!/bin/sh

# ENABLE UTF-8
LANG=en_US.UTF-8 ; export LANG

# Merge Xresources
xrdb ~/.Xresources

# UPDATE KEYMOD FILE
xmodmap "~/.Xmodmap"

# ENABLE COMPOSITING EFFECTS (Need to determine preferences and apply switches...)
# compton &

# WRITE STATISTIC INFO TO DESKTOP (need to determine preferences and apply switches...)
# conky &

# UPDATE SCREEN LAYOUT
#xrandr --output DP-5 --auto
#xrandr --output DP-4 --auto --left-of DP-5
#xrandr --output DP-7 --auto --above DP-4
#xrandr --output DP-6 --auto --above DP-5

# STARTUP APPS
pidgin &

exec $1 

.Xresources

xterm*vt100*geometry: 80x25
xterm*saveLines: 16384
xterm*loginShell: true
xterm*charClass: 33:48,35:48,37:48,43:48,45-47:48,64:48,95:48,126:48
xterm*termName: xterm-color

xterm*renderFonts:     true
xterm*boldFont:        false

xterm*faceName:        Droid Sans Mono
!xterm*faceName:        Nimbus Mono L
xterm*faceSize:        11
xterm*faceSize1:       8
xterm*faceSize2:       10
xterm*faceSize3:       12
xterm*faceSize4:       14
xterm*faceSize5:       17
xterm*faceSize6:       18

xterm*eightBitInput:   false
xterm*eightBitControl: false
xterm*eightBitOutput:  true

!BLK Cursor
#define _color0        #000d18
#define _color8        #000d18
!RED Tag
#define _color1        #e89393
#define _color9        #e89393
!GRN SpecialKey
#define _color2        #9ece13
#define _color10       #9ece13
!YEL Keyword
#define _color3        #f0dfaf
#define _color11       #f0dfaf
!BLU Number
#define _color4        #8cd0d3
#define _color12       #8cd0d3
!MAG Precondit
#define _color5        #c0bed1
#define _color13       #c0bed1
!CYN Float
#define _color6        #dfaf8f
#define _color14       #dfaf8f
!WHT Search
#define _color7        #efefef
#define _color15       #efefef
!FMT Include, StatusLine, ErrorMsg
#define _colorBD       #ffcfaf
#define _colorUL       #ccdc90
#define _colorIT       #80d4aa
!TXT Normal, Normal, Cursor
#define _foreground    #dcdcdc
#define _background    #111111
#define _cursorColor   #8faf9f

xterm*color0         : _color0
xterm*color1         : _color1
xterm*color2         : _color2
xterm*color3         : _color3
xterm*color4         : _color4
xterm*color5         : _color5
xterm*color6         : _color6
xterm*color7         : _color7
xterm*color8         : _color8
xterm*color9         : _color9
xterm*color10        : _color10
xterm*color11        : _color11
xterm*color12        : _color12
xterm*color13        : _color13
xterm*color14        : _color14
xterm*color15        : _color15
xterm*colorBD        : _colorBD
xterm*colorIT        : _colorIT
xterm*colorUL        : _colorUL
xterm*foreground     : _foreground
xterm*background     : _background
xterm*cursorColor    : _cursorColor

special-directories

mkdir -p ~/.vim/backup
mkdir -p ~/.vim/tmp

~/.vimrc

" PREFERENCES
colorscheme ron
set guifont=ProFont
set foldmethod=marker
set number

" SYNTAX
filetype on
filetype plugin on
syntax enable

" INDENTION OPTIONS
set autoindent 
set expandtab
set smarttab
set shiftwidth=2
set softtabstop=2

" LINE LENGTH
highlight ColorColumn ctermbg=gray
set cul
set colorcolumn=80

" MOUSE MODE
set mouse=a

" BACKUP/TEMP FILES
set backup
set backupdir=~/.vim/backup
set directory=~/.vim/tmp

" FUNCTIONS
" ################################################

":w open link in line via browser
function! Browser()
  let line = getline (".")
  let line = matchstr (line, "http[^   ]*")
  let line = exec "!xdg-open ".line
endfunction
map w: call Browser()

filetype plugin indent on
syntax on

/etc/rc.conf

# KERNEL MODULES NOT AVAILABLE UNTIL AFTER ROOT IS MOUNTED
kld_list="/boot/modules/i915kms.ko /boot/kernel/iwm8265fw.ko /boot/kernel/if_iwm.ko"

# NETWORK 
hostname="ux-4j5jrc2"
ifconfig_em0="DHCP"
wlans_iwm0="wlan0"
ifconfig_wlan0="WPA DHCP"

# DEBUGGING
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"

# FILESYSTEM
zfs_enable="YES"
clear_tmp_enable="YES"

# ENABLE GRAPHICS
dbus_enable="YES"
slim_enable="YES"

# POWER MANAGEMENT
powerd_enable="YES"

# GENERAL SERVICS
syslogd_flags="-ss"
sendmail_enable="NONE"
sshd_enable="YES"
moused_enable="YES"
ntpd_enable="YES"
local_unbound_enable="YES"

# WEBCAM SERVICES
webcamd_enable="YES"
webcamd_0_flags="-d 0.2"

# WPA_SUPPLICANT
wpa_supplicant_program="/usr/local/sbin/wpa_supplicant"

# BLUETOOTH
bthidd_enable="YES"
ubthidhci_enable="YES"
ubthidhci_busnum="0"
ubthidhci_addr="5"
hcsecd_enable="YES"
sdpd_enable="YES"


# ENABLE LINUX EMULATION
linux_enable="YES"
local_startup="/usr/local/etc/rc.d"

/boot/loader.conf

# $FreeBSD: head/boot/loader.conf $
# 
# This file is read and executed on boot by the freebsd loader, it sets
# the environment for the KERNEL.
#

# SYSCTL VARIABLES WHICH MUST BE SET DURING BOOT. 
vfs.root.mountfrom="zfs:zroot/ROOT/default"
kern.geom.label.disk_ident.enable="0"
kern.geom.label.gptid.enable="0"
net.fibs="3"
legal.intel_iwm.license_ack=1

# DISABLE BEASTIE LOADER
beastie_disable="YES"
#splash_bmp_load="YES"
#bitmap_load="YES"
#bitmap_name="/boot/splash/bmp"

# GELI CONFIG (FULL DISK CRYPTO)
geli_ada0p5_keyfile0_load="YES"
geli_ada0p5_keyfile0_type="ada0p5:geli_keyfile0"
geli_ada0p5_keyfile0_name="/boot/encryption.key"
aesni_load="YES"
geom_eli_load="YES"

# ZPOOL CONFIG
zpool_cache_load="YES"
zpool_cache_type="/boot/zfs/zpool.cache"
zpool_cache_name="/boot/zfs/zpool.cache"

# PROMPT FOR GELI AND START ZFS
geom_eli_passphrase_prompt="YES"
zfs_load="YES"

# ENABLE LINUX EMULATION
linprocfs_load="YES"
linsysfs_load="YES"
linux_load="YES"
lindev_load="YES"

# ENABLE WIFI FOR INTEL 8260 (IWM)
#iwm8265fw_load="YES"
#if_iwm_load="YES"

# ENABLE WEBCAM KMOD
cuse_load="YES"

# LOAD BLUETOOTH
ng_ubt_load="YES"
#ng_hci_load="YES"
#ng_bluetooth_load="YES"
#

# LOAD SIERRA WIRELESS WWAN
u3g_load="YES"

/etc/sysctl.conf

# $FreeBSD: head/etc/sysctl.conf 112200 2003-03-13 18:43:50Z mux $
#
#  This file is read when going to multi-user and its contents piped thru
#  ``sysctl'' to adjust kernel values.  ``man 5 sysctl.conf'' for details.
#

## THE FOLLOWING ARE READ-ONLY AND ARE SET IN /boot/loader.conf
# vfs.root.mountfrom="zfs:zroot/ROOT/default"
# kern.geom.label.disk_ident.enable="0"
# kern.geom.label.gptid.enable="0"
# net.fibs=3
# legal.intel_iwm.license_ack=1


## THE FOLLOWING ARE READ-WRITE (WITH ROOT) AND ARE SET DURING TRANSITION TO USER-MODE
security.bsd.see_other_uids=0
security.bsd.see_other_gids=0
security.bsd.see_jail_proc=0
security.bsd.unprivileged_read_msgbuf=0
security.bsd.unprivileged_proc_debug=0
kern.randompid=1
vfs.zfs.min_auto_ashift=12
kern.ipc.shm_allow_removed=1

# fix video suspend/resume
hw.acpi.reset_video=1
hw.acpi.sleep_delay=30

# set suspend options
hw.acpi.suspend_state=S3
hw.acpi.standby_state=S3
hw.acpi.lid_switch_state=S3
hw.acpi.sleep_button_state=S3
hw.acpi.power_button_state=S4
Advertisement